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1. PRISE EN MAIN DE QGIS
Notions abordées :

• données vecteur et raster
• composante spatiale et attributaire
• Formats de données vecteur et raster : SHP, TAB, GEOTIFF
• Projet QGS

Dans cette première partie,  nous allons aborder  ce qu'est  un logiciel  SIG,  et  quelles sont  les
données traitées par ces logiciels. Nous verrons également ce qu'est un projet SIG.

1.1. Qu'est-ce que la géomatique et les SIG ?

Selon le Journal Officiel  de 1994,  la  géomatique est l'ensemble des techniques de traitement
informatique des données géographiques. Elle regroupe donc les outils et méthodes permettant
l'acquisition, le stockage, le traitement et la diffusion de données à référence spatiale.

Un  Système  d'Information  Géographique  (SIG) est  un  système  permettant  de  gérer  des
informations localisées géographiquement. Ce système est composé de :

• données 
• logiciels 
• matériel informatique 
• savoir-faire 
• utilisateurs 

Par abus de langage, un SIG signifie souvent aujourd'hui le logiciel utilisé dans un SIG.

1.2. Quelles sont les données des SIG ?

1.2.1 Une organisation par couches

Les données sont organisées sous forme de couches superposables.

Lancez le logiciel QGIS. Ouvrez un projet :

Menu  Projet  →  Ouvrir (ou  bien  cliquez  sur  l'icône  correspondante).Sélectionnez  le
fichier senegal.qgs situé dans 1_prise_en_main/projets, cliquez sur Ouvrir.
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Trois couches de données sont affichées dans QGIS, correspondant aux villes, rivières et régions
du Sénégal.

Dans la partie gauche de la fenêtre de QGIS, vous pouvez cocher ou décocher des couches
pour les rendre visibles ou invisibles, et les faire glisser les unes par rapport aux autres pour
modifier l'ordre d'affichage.

1.2.2 Deux grands types de données : vecteur et raster

On distingue généralement deux types de données : vecteur et raster.

Les données vecteur se définissent uniquement par des coordonnées. On trouvera des données
vecteurs de type point, ligne et polygone. Un point sera défini par un couple de coordonnées XY,
une ligne ou un polygone par les coordonnées de leurs sommets.

Une couche vecteur sera soit de type point, soit de type ligne, soit de type polygone, mais ne
pourra contenir de données de deux types différents (sauf dans le cas particuliers de certains
formats qui ne seront pas abordés dans cette formation).

On pourra choisir par exemple de représenter des cours d'eau sous forme de ligne, des villes sous
forme de points...

Les données vecteur sont généralement moins volumineuses que les données raster. Quelques
exemples de formats vecteur : SVG, AI, SHP...

Les données raster, ou images, sont constituées de pixels. En zoomant sur un raster, on finit par
distinguer les pixels. Chaque pixel possède une valeur correspondant par exemple à sa couleur,
ou à son altitude. Un raster est caractérisé par la taille d'un pixel, ou  résolution. Exemples de
données raster : carte IGN scannée, photographie aérienne, image satellite...
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1.2.3 Les données vecteur : à chaque géométrie ses attributs (et vice-versa)

On distingue deux composantes dans les données utilisées dans un SIG : spatiale et attributaire.

• La composante spatiale correspond à la localisation et la géométrie d'un objet, donc à
ses coordonnées

• La composante attributaire correspond aux données qui sont associées à un objet.

Par  exemple,  la  composante  spatiale  d'un  département  sera  le  polygone  représentant  ce
département, et sa composante attributaire sera son nom, son code, sa population...

Le lien entre composante spatiale et attributaire constitue une différence fondamentale avec les
logiciels de dessin (DAO) type AutoCAD.

Ouvrez le projet depts_france.qgs situé dans le dossier 1_prise_en_main/projets (il est
inutile de sauvegarder le projet actuel)

Ouvrez  la  table  attributaire  de  la  couche  de  départements :  
Clic droit sur le nom de la couche → Ouvrir la table d'attributs

Pour que la table attributaire s'ouvre dans une fenêtre « ancrée » dans QGIS : menu Préférences → Options
→ rubrique Sources de données, cocher la case « Ouvrir la table d'attributs dans une fenêtre intégrée » (le
redémarrage n'est pas nécessaire).

Sélectionner un département dans la table attributaire, en cliquant sur le numéro de la ligne : le
département  correspondant  apparaît  dans une couleur  différente (jaune par  défaut)  dans la
carte.

Vous pouvez maintenant  faire l'inverse :  sélectionner  un département sur la  carte,  au
moyen de l'outil de sélection. La ligne correspondante passe alors en surbrillance dans la
table attributaire.

1.2.4 Des données sur les données : les métadonnées

Afin de savoir quelles sont les utilisations que l'on peut faire d'une donnée, il est indispensable de
posséder des informations sur la manière dont a été fabriquée cette donnée, sa date, ses limites
éventuelles d'utilisation...  Ces « données sur la donnée » constituent ce qu'on appelle des
métadonnées. Elles peuvent se présenter sous diverses formes : une page web, un fichier XML,
un simple fichier texte, une fiche PDF...
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Vous  pouvez  voir  ici  les  métadonnées  de  la  couche  Corine  Land  Cover :
www.geocatalogue.fr/Detail.do?id=7665

Il existe aujourd'hui des normes régissant la manière dont sont construites ces métadonnées :
nombres de rubriques présentes, choix des rubriques... Ceci permet de construire des catalogues
de métadonnées, et facilite in fine l'échange de données entre organismes.

La métadonnée ci-dessus est tirée du catalogue de métadonnées de l'IGN : www.geocatalogue.fr

1.3. Manipuler de l'information géographique

1.3.1 Ajout d'une couche vecteur

Créez  un  nouveau  projet  QGIS :  menu  Projet  →  Nouveau,  ou  bien  icône
correspondante tout en haut à gauche (il est inutile de sauvegarder le projet actuel).

Dans QGIS, ajoutez une couche vecteur. Il existe pour cela plusieurs solutions, au choix :

• menu Couche → Ajouter une couche → Ajouter une couche vecteur...

• cliquer sur l'icône Ajouter une couche vecteur

• utiliser le raccourci clavier ctrl + majuscule + v

• Type de source et codage : laissez les valeurs par défaut

Pour en savoir plus sur ce qu'est l'encodage : http://fr.wikipedia.org/wiki/Codage_de_caractères

• Source : cliquer sur  Parcourir et sélectionner la couche Depts_Aqui_Geofla.shp située
dans  1_prise_en_main/donnees.  Pour  repérer  plus  facilement  cette  couche,  choisir  ESRI
Shapefiles comme type de fichier.
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Cliquer sur Ouvrir, puis à nouveau sur Ouvrir : vous pouvez voir les départements aquitains.

Toujours pour ajouter une couche, vous pouvez également passer par le panneau Parcourir :
activez-le dans le menu Vue → Panneaux → Explorateur. Dans ce panneau, naviguez dans
l'arborescence de vos fichiers jusqu'à trouver le répertoire de partage. Faites un clic droit sur le
dossier  donnees → Ajouter en favori. A partir des favoris, rendez-vous maintenant dans le
dossier 1_prise_en_main/donnees et double-cliquez sur la couche Depts_Aqui_Geofla.shp.

1.3.2 L'interface de QGIS

1 Menus

2 Barres  d'outils. On  y  trouve  la  même  chose  que  dans  les  menus,  mais  sous  forme  
d'icônes.  Pour savoir que fait un outil, passez la souris au-dessus et lisez l'infobulle.  Pour  
rajouter ou enlever des barres d'outils : menu Vue → Panneaux → Barres d'outils.

3 Liste  des couches chargées,  aussi  appelée  table des matières ou  table  of  contents 
(TOC). Si plusieurs couches sont présentes, vous pouvez en modifier ici l'ordre d'affichage.  
Pour faire apparaître ou disparaître cette zone : menu Vue → Panneaux → Couches

4 Panneaux supplémentaires, par exemple le panneau Explorateur permettant de visualiser
dossiers et données SIG. Différents panneaux sont disponibles : menu Vue → Panneaux

5 Zone de visualisation. On peut zoomer ou se déplacer dans cette zone.

6 Barre  d'état.  On  y  trouve  les  coordonnées  du  point  où  se  trouve  la  souris,  l'échelle,  le
système de coordonnées...

Testez les différents boutons de zoom et de déplacement.
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Pouvez-vous déterminer l'effet de chacun d'entre eux ?

A noter : on peut aussi zoomer et dézoomer en utilisant la molette de la souris, ainsi que le
trackpad. Si vous maintenez la touche espace appuyée, vous pouvez vous déplacer sur la carte
en bougeant la souris. Idem en laissant la molette de la souris enfoncée.

1.3.3 Propriétés d'une couche vecteur

Pour accéder aux propriétés de la couche,  clic-droit sur le nom de la couche dans la table
des matières, Propriétés (ou bien double-clic sur le nom de la couche).

Vous avez accès ici à plusieurs propriétés, notamment :

• la  manière  dont  la  couche  est  représentée,  dans  la  rubrique  Style.  Vous  pouvez  par
exemple changer ici la couleur des départements 

• l'emplacement de la couche, dans la rubrique Général 

Dans les propriétés de la couche, rubrique Style, cliquez sur Remplissage simple :

1 Dans  la  partie  Couleurs,  vous  pouvez  modifier  la  couleur  du  fond  et  de  la  bordure  des
départements.

2 Vous pouvez également modifier le style de remplissage : plein, vide, hachures... ainsi que le
style de la bordure : ligne continue, pas de bordure, pointillés...

3 La largeur de la bordure peut aussi être modifiée.

Essayez de donner à votre couche ces différents styles :
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Pour connaître l'emplacement d'une couche :

Rendez-vous dans les propriétés de la couche, rubrique Général, Source de la couche.

1.3.4 Ajout d'une couche raster

Ajoutez une couche raster, soit en passant par le menu Couche → Ajouter une couche
→ Ajouter une couche raster..., soit en cliquant sur l'icône correspondante

Rendez-vous  dans  le  dossier  1_prise_en_main/donnees et  sélectionnez  la  couche
srtm_aqui.tif.

Cliquez sur Ouvrir : la couche s'affiche.

Vous pouvez également ajouter cette couche à partir du panneau Explorateur.

Il  s'agit  d'un  modèle d'élévation numérique : chaque pixel possède
une valeur correspondant à l'altitude en mètres des éléments présents
au sol. Si une forêt est présente, ce sera donc l'altitude du sommet des
arbres qui sera mesurée et non l'altitude du sol, idem si des bâtiments
sont présents.

Après  avoir  sélectionné  la  couche
srtm_aqui.tif,  utilisez  l'outil  Identifier
les entités pour cliquer sur un point du

raster et connaître l'altitude de ce point.

Par  exemple,  ici,  c'est  un  point  d'altitude  693
mètres qui a été identifié.
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1.4. Formats de données SIG

Réduire la fenêtre de QGIS. Ouvrir dans l'explorateur de fichiers de votre ordinateur le dossier
1_prise_en_main/donnees.

1.4.1 Format Shapefile ou SHP : un « standard »

Le format shapefile a été créé par ESRI, l'éditeur notamment du logiciel SIG ArcGIS. Ce format est
aujourd'hui l'un des standards du SIG et est couramment utilisé par les logiciels libres de SIG.

Un fichier SHP est en fait composé de plusieurs fichiers, dont 3 sont obligatoires :

• SHP : contient les informations spatiales
• DBF : contient les informations attributaires
• SHX : fichier d'index

Le format DBF impose certaines limitations pour les noms de colonnes : maximum 10 caractères,
éviter les accents...

Un 4ème fichier est aussi bien utile :

• PRJ : contient le code du système de coordonnées et éventuellement de la projection (cf.
partie 2 : Notions de géodésie)

Pour que le shapefile s'ouvre correctement, tous ces fichiers doivent avoir exactement le même
nom et être au même endroit. QGIS peut ouvrir et éditer les fichiers SHP.

1.4.2 Format TAB (MapInfo)

Ce format a été créé pour le logiciel MapInfo. Comme pour le SHP, un fichier au format TAB est en
fait composé de plusieurs fichiers :

• MAP : données spatiales (avec le système de coordonnées)
• DAT : données attributaires
• TAB : structure de la couche
• ID : lien entre les fichiers DAT et MAP
• IND : fichier d'indexation (facultatif)
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QGIS peut ouvrir des fichiers au format TAB, mais il ne peut pas les éditer ; il faudra pour cela les
enregistrer au format SHP.

1.4.3 Formats raster : l'exemple du TIF

La couche srtm_aqui est au format TIF. Ce format permet de stocker les coordonnées du pixel en
haut à gauche de l'image, ainsi que le système de coordonnées de l'image : il s'agit en réalité d'un
GEOTIFF. Ce format est lisible par la plupart des logiciels SIG.

Un fichier srtm_aqui.qml est également présent : ce fichier est facultatif et stocke la manière dont
est représentée la couche raster (ici, du noir au blanc, valeur les plus élevées en noir...). Ce fichier
est lisible uniquement par QGIS.

1.4.4 Application

Combien de couches sont  présentes dans le  dossier  1_prise_en_main/donnees ?  En quel
format est chaque couche ?

1.5. Espace de travail (projet QGS)

1.5.1 Qu'est-ce qu'un projet dans un logiciel SIG?

Un projet est un espace de travail. Sauvegarder un projet équivaut à sauvegarder le style utilisé
pour chaque couche, le zoom... mais pas les données ! C'est en quelque sorte un raccourci pour
éviter de recharger à chaque fois les couches sur lesquelles on travaille, les remettre dans l'ordre,
choisir les couleurs, zoomer sur la zone d'intérêt...

Ouvrez le projet senegal.qgs situé dans le dossier 1_prise_en_main/projets.

Modifiez le zoom et le style des couches (couleur, taille des points...). 

Sauvegardez votre projet sous un nouveau nom : clic sur l'icône correspondante, ou bien
menu Projet →Enregistrer sous...

Enregistrez  votre  projet  dans  le  répertoire  1_prise_en_main/projets,  sous  le  nom
senegal_02.qgs . Cette opération crée un fichier au format QGS.

Le fichier QGS est l'équivalent du WOR sous MapInfo et du MXD sous ArcGIS.

Masquez QGIS, et ouvrez ensuite ce fichier QGS au moyen d'un éditeur de texte type bloc-
notes : vous pouvez y trouver le chemin des couches chargées dans le projet, la description des
couleurs utilisées... Fermez ce fichier.

Il n'est bien sûr pas utile de comprendre en détail le contenu du fichier QGS, mais il est important
de noter qu'il ne s'agit que d'un fichier texte, qui va « appeler » les données. Si vous fournissez
à un collègue votre seul fichier QGS, sans les données correspondantes, ce collègue ne pourra
pas visualiser les données.

1.5.2 Pour aller plus loin : comment un projet appelle-t-il les données?

Le chemin des couches peut être stocké de deux manières dans le fichier QGS :

1. soit par rapport à l'emplacement du QGS : chemin relatif
2. soit « en dur », sous la forme du chemin en entier : chemin absolu
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Dans le cas d'un chemin relatif, ../donnees/senegal_regions.shp signifie qu'il faut remonter d'un
dossier  par rapport  au dossier  dans lequel est  situé le projet,  puis descendre dans le dossier
donnees pour y trouver la couche senegal_regions.shp

Dans le cas d'un chemin absolu, le chemin est exprimé par rapport à la racine de l'ordinateur :

/home/julie/Bureau/1_prise_en_main/donnees/senegal_regions.shp

Dans QGIS, par défaut les chemins sont sauvegardés en relatif, ce qui permet de transmettre à
un collègue un dossier avec par exemple un sous-dossier données et un sous-dossier projets. 

Si vous désirez changer ce comportement pour un projet :

menu Projet → Propriétés du projet... → rubrique Général, changez la propriété Enregistrer
les chemins de relatif à absolu. 

Si vous déplacez des couches et que vous ouvrez ensuite un projet QGS qui utilise ces
couches,  vous  obtiendrez  un  message  d'erreur :  le  chemin  des  couches  a  changé  et  ne
correspond plus à ce qui est indiqué dans le fichier QGS ! Il est néanmoins possible de spécifier à
nouveau l'emplacement des couches manquantes.
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2. NOTIONS DE GÉODÉSIE

Notions abordées : 

• ellipsoïde et géoïde
• coordonnées géographiques
• coordonnées projetées
• SCR d'une couche
• SCR d'un projet

Dans  cette  deuxième  partie,  nous  verrons  qu'il  existe  plusieurs  manières  d'exprimer  les
coordonnées d'un point, et les conséquences à en tirer dans l'utilisation d'un logiciel SIG.

Introduction
La géodésie est la science qui étudie la forme et les dimensions de la Terre, en tenant compte de
son  champ  de  pesanteur.  Nous  aborderons  ici  les  différentes  manières  d'exprimer  des
coordonnées, et comment cela se traduit-il dans un logiciel SIG.

La  surface  de  la  Terre  est  très  irrégulière  et  complexe,  on  peut  la  modéliser  de  différentes
manières.

La sphère est le modèle le plus simple.

L'ellipsoïde est une sphère aplatie, plus simple à modéliser. On le définit généralement par ses
demis-axes (a, b et c) et son centre (O).

Le géoïde est une surface perpendiculaire en tout point à la direction de la gravité (fil à plomb).
Cette surface passe par le niveau moyen des mers. Les altitudes sont mesurées par rapport au
géoïde depuis les années 1960 (altitude normale). On peut considérer le géoïde comme un sphère
cabossée. C'est une représentation exacte mais compliquée à utiliser.

Il existe une infinité d'ellipsoïdes, qui peuvent coïncider avec la surface de la Terre sur toute leur
surface (ellipsoïde global) ou seulement sur une partie de leur surface (ellipsoïde local). A l'inverse,
il n'existe qu'un seul géoïde.

2.1. Des coordonnées, oui mais dans quel système ?

2.1.1 Qu'est-ce qu'un système de coordonnées ?

Un système de coordonnées est un système utilisé pour mesurer
des coordonnées. Il peut être défini par un ellipsoïde. Un point sera
alors localisé par ses coordonnées géographiques, exprimées par
la latitude  Ф, la longitude  λ, et la hauteur ellipsoïdale  h mesurée
suivant la normale à l'ellipsoïde.

Longitude et latitude sont des mesures d'angles et  peuvent  être
exprimées en degrés, en grades ou en radians.
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Attention à ne pas confondre la hauteur ellipsoïdale, mesurée par rapport à l'ellipsoïde, et l'altitude normale
mesurée par rapport au géoïde. Avant les années 1960, les altitudes étaient mesurées par rapport au niveau
de la mer (altitude orthométrique).

Il  existe  de  nombreux  systèmes  de  coordonnées.  Ils  sont  recensés  par  l'EPSG  (European
Petroleum Survey Group) qui a attribué un code à chacun. Quelques exemples :

WGS84 (World Geodetic System 1984), code EPSG 4326 :
Système global initialement mis au point par le département de la défense des États Unis en 1984,
mis à jour en 2004. Son exactitude est métrique, et son ellipsoïde se nomme IAG-GRS80.

RGF93 (Réseau Géodésique Français 1993), code EPSG 2154 :
Système global obtenu par densification des points du réseau mondial associé ETRS89. Il s'agit
du système officiel français. Ce système est facilement compatible avec le WGS84 par exemple.

Certains  systèmes  seront  adaptés  à  une  zone  précise,  d'autre  à  la  Terre  entière.  Plusieurs
systèmes coexistent  souvent  pour  une  même zone,  en  raison  par  exemple  de  l'avancée  des
techniques ou de règlements.

Un même point aura des coordonnées différentes selon le système utilisé pour les mesurer.
Le tableau ci-dessous montre les coordonnées de Paris dans différents systèmes.

Système de coordonnées Code Latitude (degrés) Longitude (degrés)

WGS84 EPSG:4326 48,856700 2,351000

ED50 EPSG:4230 48,857615 2,352286

RGF93 EPSG:4171 48,856700 2,351000

NTF EPSG:4807 48,856769 0,014494

Un point peut donc être défini par 3 coordonnées X, Y et Z dans un système de coordonnées.
Comment représenter maintenant la Terre en 2 dimensions, pour en faire une carte par exemple ?

2.1.2 Coordonnées en deux dimensions : les projections

Le principe est de projeter des données 3D sur une surface plane. Il y aura donc forcément
des déformations : pensez à une peau d'orange qu'on écrase, et qui va se déchirer.

On appelle  projection cartographique le  système de correspondance entre les  coordonnées
géographiques (donc mesurées avec un système de référence) et les points du plan de projection.

De nombreuses méthodes de projections existent, chacune adaptée à un usage différent.

Lorsqu'on utilise une projection, on parle de coordonnées projetées. Ces coordonnées sont par
définition bidimensionnelles, et seront exprimées généralement en unités métriques.

Une  projection  permet  donc  de  représenter  sur  une  surface  plane  une  partie  d'un  modèle
ellipsoïdal, mais aussi :

• de rendre plus facile une évaluation des distances et des surfaces
• dans le cas de données 3D, il est plus simple que x, y et z soient tous exprimés en mètres

Dans tous les cas, on va projeter la surface de la Terre sur une forme que l'on peut dérouler pour
obtenir une surface plane : un cylindre, un cône ou un plan. On distingue ainsi les  projections
cylindriques,  coniques et  azimutales  (il  existe également  d'autres types de projections  plus
complexes).
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On peut aussi classer les projections selon leurs propriétés. On distingue ainsi :

• les projections équivalentes qui conservent les surfaces 
• les projections conformes qui conservent les angles
• les  projections  aphylactiques,  ni  conformes  ni  équivalentes.  Elles  peuvent  être

équidistantes, c'est-à-dire conserver les distances sur les méridiens.

Une projection ne peut être à la fois conforme et équivalente.

Il existe d'autres types de projections, ni équivalentes, ni conformes et ni azimutales.

Pour visualiser les déformations liées à une projection, on peut utiliser les indicatrices de Tissot.
Ce sont des cercles identiques dessinés sur la Terre avant projection, qui se retrouveront donc
déformés après projection. Si la projection déforme les angles, les cercles seront transformés en
ellipses, si elle déforme les surfaces les cercles auront des surfaces différentes.

Un même point aura des coordonnées différentes selon la projection utilisée (et le système
associé  à  cette  projection).  Ci-dessous,  les  coordonnées  de  Paris  mesurées  dans  différents
systèmes et projections.

Système et projection Code X (en mètres) Y (en mètres)

Mercator EPSG:54004 261712,122 6218386,300

Peters SR-ORG:22 185368,909 6753027,140

RGF93 Lambert93 EPSG:2154 652381,068 6862047,100

Azimutale équidistante pôle sud EPSG:102019 632368,408 15402681,400

En résumé, la projection parfaite n'existe pas; il faut essayer de faire au mieux pour l'usage
auquel  on  destine  la  carte.  Par  exemple,  les  cartes  utilisées  pour  la  navigation  conservent
généralement les angles et non les distances. L'échelle de la carte influe également sur le choix de
la projection.

2.1.3 A retenir

On peut exprimer les coordonnées d'un point :

• sous  forme  de  coordonnées  géographiques  en  degrés :  latitude,  longitude,  hauteur
ellipsoïdale. Ces coordonnées sont calculées  dans un système géodésique de référence,
sans utilisation de projection

• sous forme de coordonnées en projection en mètres (représentation plane), calculées dans
un système géodésique de référence et avec une projection cartographique

Pour simplifier, dans le reste de ce tutoriel, le système de coordonnées et sa projection associée
s'il  y  en  a  une  seront  nommés  SCR  (Système de  Coordonnées  de  Référence) suivant  la
terminologie utilisée par QGIS.
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2.2. Couches et projets : à chacun son système

2.2.1 SCR du projet

A  partir  de  QGIS,  ouvrez  le  projet  regions_france.qgs situé  dans  le  dossier
2_geodesie/projets.

Toutes les couches chargées dans ce projet seront affichées dans le SCR du projet. Quel est
ce SCR ? Trois manières pour accéder à cette information :

• Menu Projet → Propriétés du projet..., rubrique SCR

• Icône statut de la projection tout en bas à droite de la fenêtre de QGIS  

• raccourci clavier Ctrl+Maj+P → rubrique SCR 

La fenêtre suivante s'ouvre :

1  Projection à la volée : cette fonctionnalité sera décrite dans la partie 2.2.3 Projection à la volée.

2  Partie "recherche" : vous pouvez taper ici un code ou un nom pour rechercher un système
précis.

3  Liste des derniers SCR utilisés (cette partie peut être vide).  Cette liste permet d'accéder
facilement aux SCR que vous utilisez souvent.

4  Liste de tous les SCR disponibles dans QGIS. Ils sont classés selon 3 grandes rubriques :
systèmes de coordonnées géographiques,  systèmes de coordonnées projetés et  systèmes de
coordonnées définis par l'utilisateur (soit qu'ils aient été créés par vous-même, soit qu'ils aient été
lus par QGIS dans une couche).

5  SCR actuellement utilisé par le projet
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Cette fenêtre permet donc de modifier le système de coordonnées du projet, ou bien simplement
de vérifier quel est ce système, ce que nous nous bornerons à faire pour le moment.

A votre avis, quel est le SCR du projet ?

Notez également que le code du SCR du projet est indiqué tout en bas à droite de la fenêtre de
QGIS, dans la barre d'état de QGIS :

2.2.2 SCR d'une couche

Nous  allons  maintenant  chercher  à  savoir  dans  quel  SCR  est  la  couche
Reg_France_Geofla_L93.shp.

Ouvrez les propriétés de cette couche et allez dans la rubrique Général :

Quel est le SCR de Reg_France_Geofla_L93 ?

Vous avez donc pu constater  que notre projet et la couche qui y est présente ont  deux SCR
différents. Comment cela est-il possible?

2.2.3 Projection à la volée

La projection à la volée est une fonctionnalité qui permet d'afficher des couches dans un autre
SCR que le leur, le SCR du projet.

Ainsi,  la  couche  Reg_France_Geofla_L93 est  affichée en WGS84 bien que son SCR soit  le
RGF93 Lambert93. Il s'agit bien uniquement d'une question d'affichage, le SCR de la couche n'est
pas modifié.
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A partir  du moment où la projection à la volée est activée dans un projet,  toutes les couches
affichées dans ce projet le seront dans le SCR du projet.

Il est donc possible de superposer plusieurs couches dans des SCR différents. C'est ce que nous
allons vérifier!

Ajoutez la couche 2_geodesie/donnees/ne_110m_admin_0_countries.shp au projet. Vérifiez
son  SCR.  Les  deux  couches  doivent  se  superposer  correctement  (même si  elles  ont  des
niveaux de généralisation différents) ; si ce n'est pas le cas vérifiez que la projection à la volée
soit bien activée (cf. 2.2.1 SCR du projet p. 16).

La projection à la volée peut être activée ou désactivée par défaut :

menu Préférences → Options, rubrique SCR

Laissez cochée la case Activer automatiquement la projection à la volée si les couches ont
des SCR différents. Ainsi, chaque projet que vous créerez dans QGIS aura automatiquement
cette fonctionnalité activée.

Pour vérifier d'un coup d’œil si la projection à la volée est activée, regardez l'icône du statut de la
projection tout en bas à droite de la fenêtre de QGIS, dans la barre d'état :

• projection à la volée est activée → l'icône et le code du SCR du projet sont gris foncé, avec
les lettres OTF (On The Fly)

  
• projection  à  la  volée  est  désactivée  → l'icône  et  le  code  du  SCR  sont  gris  clair

2.3. Passer d'un système de coordonnées à un autre

2.3.1 Modifier le SCR du projet

Vous avez pu constater dans la partie 2.2 que les couches d'un projet sont affichées dans le SCR
du projet. Comment modifier le SCR du projet pour afficher les couches dans le SCR de votre
choix ?

Nous allons modifier le SCR du projet monde.qgs du WGS84 vers Robinson (code EPSG 53030).

Pour en savoir plus sur la projection de Robinson : http://fr.wikipedia.org/wiki/Projection_de_Robinson

Ouvrez le projet monde.qgs situé dans le dossier 2_geodesie/projets (il est inutile de
sauvegarder le projet actuel).

Ce projet comporte une couche de pays, une couche avec les indicatrices de Tissot (cf. partie
2.1.2), et une couche de graticule, c'est-à-dire de méridiens et de parallèles distants ici de 15
degrés.

Dans quel SCR sont les 3 couches du projet ?

Pour modifier le SCR du projet : menu Projet → Propriétés du projet,
rubrique SCR, ou clic sur l'icône en bas à droite de QGIS :
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1  Vérifiez que la projection à la volée soit bien activée.

2  Tapez robinson dans cette partie, ou bien 53030.

3  Le filtre est activé dans la liste des derniers SCR utilisés. Selon si vous avez déjà utilisé
Robinson,  cette  partie  sera donc ou vide ou avec une ou deux lignes correspondant  à  ce
système.

4  Le filtre est également activé dans la liste de tous les SCR disponibles : seuls les SCR dont le
nom contient « Robinson » sont affichés. Sélectionnez Sphere Robinson, code EPSG 53030.

5  Vous devez voir dans cette partie le SCR que vous venez de sélectionner.

Cliquez sur OK.

La  couche de pays est  désormais  affichée en Robinson.  Son SCR n'a  cependant  pas  été
modifié, ce que vous pouvez vérifier. Observez les modifications apportées aux pays et aux
indicatrices de Tissot.

Répétez cette manipulation pour que le SCR du projet passe en :

• Mercator, code EPSG 54004 

• Projection azimutale équidistante du pôle Sud, code EPSG 102019 

• RGF93 / Lambert-93, code EPSG 2154 

Que constatez-vous dans ce dernier cas ? Pourquoi ?
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2.3.2 Modifier le SCR d'une couche

Nous avons vu que QGIS gère le cas où plusieurs couches dans différents SCR sont affichés dans
un même projet. Cependant, certaines manipulations nécessitent que toutes les couches soient
dans le même SCR. Par ailleurs, par souci de clarté et pour éviter les erreurs, on peut vouloir
travailler avec des couches dans le même SCR.

Pour toutes ces raisons, il est utile de savoir modifier le SCR d'une couche.

Cette manipulation implique de  recalculer les coordonnées de tous les objets de la couche
dans un autre SCR.

Par exemple, si la couche d'origine est en WGS84 et contient un point correspondant à la ville de
Paris, et que le but est d'obtenir une couche en RGF93 / Lambert-93 , les coordonnées initiales du
point  (48,856700  2,351000  en  WGS84)  seront  recalculées  pour  devenir  (652381.068
6862047.100) en RGF93 / Lambert-93.

Cette  manipulation  crée  une nouvelle  couche.  La  couche  d'origine  et  la  couche  résultat  se
superposeront  exactement  dans  QGIS  si  la  projection  à  la  volée  est  activée,  puisqu'elles
contiendront exactement les mêmes objets.

L'objectif sera ici de créer une nouvelle couche pays en Sphere Bonne (EPSG 53024) :

Clic-droit sur la couche ne_110m_admin_0_countries → Enregistrer sous...

• Format : laisser ESRI Shapefile pour que la couche qui sera créée soit au format SHP

• Enregistrer  sous : cliquer  sur  le  bouton  Parcourir,  rendez-vous  dans  le  répertoire
2_geodesie/donnees et tapez le nom de la couche qui va être créée : pays_bonne

• SCR : cliquez sur l'icône à droite et sélectionnez le SCR Sphere_Bonne, code EPSG 53024
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• laissez  les  autres  options  par  défaut,  en  vérifiant  que  la  case  Ajouter  les  fichiers
sauvegardés  à  la  carte soit  bien cochée, afin  que la  nouvelle  couche soit  directement
ajoutée dans QGIS

Cliquez sur OK.

Si vous avez bien coché la case correspondante, la couche est automatiquement ajoutée à la
carte. Sinon, ajoutez-la dans QGIS.

Vérifiez dans ses propriétés que son SCR soit bien Sphere Bonne.

Vous pouvez si  vous le  voulez modifier  également le SCR du
projet  en Sphere Bonne.  Il  existe un raccourci  pour  cela :  clic
droit sur la couche en Bonne, Définir le SCR du projet depuis
cette  couche.  Le  projet  prend alors  le  même SCR que cette
couche.

2.3.3 Redéfinir le SCR d'une couche

Il existe une autre manipulation souvent confondue avec le fait de modifier le SCR d'une couche :
redéfinir le SCR d'une couche. Dans ce cas, les coordonnées ne sont pas recalculées et aucune
nouvelle couche n'est créée, le SCR associé à la couche est simplement modifié.

Pour  reprendre  l'exemple  utilisé  plus  haut  d'une  couche  en  WGS84  contenant  un  point
correspondant  à  la  ville  de Paris  de coordonnées  (48,856700  2,351000),  si  le  SCR de  cette
couche  est  redéfini  en  RGF93  /  Lambert-93,  les  coordonnées  du  point  resteront  (48,856700
2,351000) mais ces coordonnées seront renseignées comme étant mesurées dans le SCR RGF93
/ Lambert-93.

Le point ne sera donc pas affiché, ou affiché à un endroit aberrant, puisqu'il n'est pas possible de
trouver de telles coordonnées dans ce SCR (en RGF93 / Lambert-93, les X varient de 100 000 à 1
200 000 et les Y de 6 000 000 à 7 100 000).

Redéfinir le SCR d'une couche n'est donc utile que dans deux cas bien précis :

• le SCR n'est pas défini du tout, ce qui peut arriver par exemple pour certaine couches
trouvées sur internet. Il faudra alors retrouver dans quel SCR a été initialement créée la
couche 

• le  SCR  est  mal  défini (quelqu'un  –  ou  vous-même !  -  a  donc  déjà  effectué  cette
manipulation à tort) 

Pour vous rendre compte à coup sûr si une couche n'a pas de SCR défini, rendez-vous dans le
menu Préférences → Options → rubrique SCR :

Pour l'option  Quand une nouvelle couche est créée ou quand une couche est chargée
sans SCR, vérifiez que l'option Demander le SCR soit bien celle sélectionnée.

Ainsi,  si  vous chargez une couche dont  le  SCR n'est  pas défini,  QGIS vous avertira  et  vous
demandera de spécifier un SCR pour cette couche (ce sera cependant à vous de retrouver le SCR
initial dans lequel aura été créée cette couche).
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3. MANIPULER DES DONNÉES VECTEUR

Notions abordées :

• Création d'une couche de points à partir d'un fichier texte XY
• Requêtes attributaires
• Requêtes spatiales
• Géotraitements (découpage, intersection)
• Calcul de champ

Dans cette troisième partie, nous verrons plusieurs exemples de manipulations sur des données
vecteurs : créer une couche de points à partir d'un fichier texte, sélectionner des données selon
différents critères, croiser des couches données, manipuler les données attributaires.

3.1. Créer une couche de points à partir d'un tableau de coordonnées

L'exemple portera ici  sur  un fichier  au format  CSV :  il  s'agit  d'un fichier  texte comportant  des
colonnes séparées par un caractère, généralement une virgule, parfois aussi un point-virgule ou
une tabulation (http://fr.wikipedia.org/wiki/Comma-separated_values).

Pour information, il est possible de créer un fichier au format CSV à partir d'un fichier ODS (Libre
Office) ou XLS (Microsoft Office) par exemple.

3.1.1 Qu'y a-t-il dans le fichier texte ?

Dans l'explorateur de votre ordinateur, ouvrez le fichier villes_bhutan.csv situé dans le dossier
3_manip_vecteur/donnees à l'aide d'un éditeur de texte simple (pas dans un tableur) : par
exemple, WordPad dans Windows, TextEdit sous Mac, gedit sous Ubuntu.

Ici, le caractère utilisé pour séparer les colonnes est le point-virgule. La première ligne contient les
en-têtes de colonnes.

Combien de colonnes y a-t-il dans le fichier  villes_bhutan.csv et comment se nomment ces
colonnes?

Quelle est la latitude de la ville de Timphu?

A votre avis, dans quel SCR sont mesurées la latitude et la longitude ?

Fermez le fichier sans enregistrer les modifications, quittez l'éditeur de texte.
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3.1.2 Visualisation des données dans QGIS

Ouvrez un nouveau projet vide dans QGIS.

Ajoutez  la  couche  ne_10m_admin_0_countries.shp située  dans  le  dossier
3_manip_vecteur/donnees. Cette couche servira à vérifier que les villes du Bhoutan
sont bien placées au Bhoutan.

Cliquez sur l'icône Ajouter une couche de texte délimité, ou bien allez dans le Menu
Couche → Ajouter une couche → Ajouter une couche de texte délimité 

• Cliquez sur le bouton Parcourir et sélectionnez le fichier villes_bhutan.csv 

• Nom de la couche : vous pouvez laisser villes_bhutan ou bien tapez le nom de votre choix 

• Format de fichier : choisir délimiteurs personnalisés et sélectionner le point-virgule 

• Définition de la géométrie : choisir les colonnes X et Y 

Cliquez  sur  OK.  Le  logiciel  vous  demande  ensuite  dans  quel  SCR  sont  mesurées  les
coordonnées du fichier CSV : choisissez le WGS84 (code EPSG 4326).

Zoomez sur la couche de points et ouvrez sa table attributaire.

3.1.3 Création du shapefile de points

Regardez  à quel  emplacement est  stockée votre couche (propriétés de la  couche,  rubrique
Général). Vous pouvez observer que cet emplacement fait référence à un fichier CSV et non à
un fichier SHP.
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Par ailleurs, si vous sélectionnez la couche de villes dans la table des matières, vous pouvez
constater que l'icône pour passer en mode édition est désactivée, au contraire de notre couche
de pays. La couche de villes n'est donc pas éditable.

Icône édition activée : Icône édition désactivée : 

Bien que nous puissions visualiser les villes dans QGIS,  aucun SHP n'a été créé,  ce qui est
d'ailleurs logique dans la mesure où QGIS ne nous a demandé à aucun moment de choisir un
emplacement pour cette couche.

En  fait,  nous  avons  seulement  créé  une couche temporaire,  uniquement  stockée  dans le
projet QGS en cours. Comment faire pour sauvegarder cette couche ?

Clic-droit sur la couche villes_bhutan → Sauvegarder sous... 

• Cliquez sur Parcourir pour sélectionner l'emplacement où la couche sera créée et lui donner
un nom

• Laissez les autres paramètres par défaut 

Cliquez sur OK; la couche est ajoutée à QGIS, vous devez donc avoir deux couches de villes
identiques au premier abord; cependant, l'une est temporaire et l'autre permanente.
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3.2. Joindre des données attributaires à une couche

3.2.1 Comment fonctionne une jointure attributaire ?

Dans un logiciel SIG, une jointure attributaire consiste à lier à une couche des données provenant
d'une table ou d'une autre couche. On se base pour cela sur les données attributaires.

Un champ de la couche de départ et un champ de la table contenant les données à joindre servent
de champs clé. Ces champs doivent être de même type (texte, nombre) et contenir les mêmes
données. Le logiciel se base sur le contenu de ces champs pour déterminer quel élément de la
table est lié à quel élément de la couche.

Dans l'illustration ci-dessus, les données de départ sont :

• une couche de polygone avec les régions du Bhoutan. La table attributaire comporte le
nom et le code de chaque région, mais pas leur population. 

• un tableau avec le code de chaque région et sa population en 1995 

Les données de la table sont jointes aux données du shapefile, en se basant sur le code région :
champ CODEREGION pour le shapefile et champ REG_CODE pour le tableau.

Au final, on obtient une couche shapefile des régions du Bhoutan, avec en données attributaires
les données de la couche de départ et les données du tableau, donc la population.

Il  arrive qu'un élément de la couche de départ  corresponde à plusieurs éléments de la  table.
Différentes stratégies sont alors possibles selon les logiciels et le type de champ : ne prendre en
compte que les données du premier élément lié, calculer la moyenne des données...
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3.2.2 Application : population au Bhoutan

Créez  un  nouveau  projet  QGIS  et  ajoutez-y  la  couche  des  régions  du  Bhoutan
regions_bhutan.shp.

Ajoutez également au projet la table  pop_bhutan.csv :  pour cela, vous pouvez soit  double-
cliquer sur ce fichier à partir du panneau explorateur, soit à partir de l'icône ou du menu en
choisissant Tous les fichiers comme format de fichier :

Vous devez donc avoir dans QGIS ces deux données (notez l'icône de tableau pour le CSV) :

Ouvrez les deux tables attributaires.

A votre avis, pour pouvoir effectuer une jointure entre les 2 tables, quels seront les 2 champs
clés ?

Allez dans les propriétés de la couche regions_bhutan, rubrique Jointure :

Cliquez sur le symbole + pour ajouter une jointure :
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Choisissez les données à joindre : pop_bhutan et les champs clés.

Notez qu'on peut choisir d'ajouter ou non chaque champ de la couche à joindre !
Cochez la case Personnaliser le préfixe du champ, afin de choisir le préfixe des champs qui
seront ajoutés grâce à cette jointure : CSV_ .

Vous pouvez également laisser vide cette case, pour ne pas ajouter de préfixe aux noms des champs joints.
Attention cependant, dans ce cas s'il existe déjà des champs de même nom dans la table d'origine, cela
peut causer des problèmes.

Ouvrez la table attributaire de la couche regions_bhutan.shp : les données de la table ont été
ajoutées (champ CSV_POPEST95).

Cependant, la couche n'a pas été modifiée, la jointure n'est que temporaire. Pour sauvegarder
définitivement la jointure, il faut sauvegarder la couche sous un autre nom.

Notez également que les champs joints pourront  être renommés, à l'aide de l'extension  Table
Manager.

3.3. Sélectionner des entités selon leurs attributs

Nous allons voir ici comment utiliser les données de la table attributaire pour sélectionner des
éléments  d'une  couche,  par  exemple  comment  sélectionner  les  départements  dont  le  nom
commence par « A ».

Nous ne passerons en revue que quelques unes des possibilités de QGIS en matière de requête
attributaire. Pour une description de tous les opérateurs et fonctions possibles : voir  le manuel
QGIS :http://docs.qgis.org/2.8/fr/docs/user_manual/working_with_vector/expression.html#vector-
expressions (cette partie correspond à la calculatrice de champ mais est valable également pour
les requêtes attributaires).

3.3.1 Faire une requête simple

Créez un nouveau projet QGIS.

Ajoutez  la  couche  departements.shp située  dans  le  dossier  3_manip_vecteur/donnees.
Ouvrez la table attributaire de cette couche.
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Nous avons vu précédemment comment sélectionner une entité en cliquant sur le numéro de la
ligne correspondante ou bien directement sur cette entité sur la carte (cf. 1.2.3 p. 5). Vous pouvez
aussi passer par une requête attributaire :

Dans la barre d'outils située en haut de la table attributaire, cliquez sur l'icône Sélectionner les
entités en utilisant une expression :

La fenêtre de requête attributaire s'ouvre :

Pour faire une requête simple, par exemple pour sélectionner le département du Nord :

• Cliquez sur Champs et valeurs dans la colonne du milieu : la liste des champs de la table
apparaît

• Double-cliquez sur le champ NOM_DEPT pour le faire apparaître dans la case Expression à
gauche de la fenêtre (notez les guillemets doubles)

• Cliquez sur l'opérateur = en haut à gauche

• Cliquez sur le bouton Charger les valeurs uniques : Toutes pour voir dans la case Valeurs la
liste des valeurs uniques du champ (ici, NOM_DEPT)

• Double-cliquez sur la valeur 'NORD' (notez les guillemets simples)

• A ce stade, la case Expression doit contenir : "NOM_DEPT" = 'NORD'

• Cliquez sur le bouton Sélection en bas de la fenêtre

La fenêtre de requête attributaire ne se ferme pas automatiquement ; vous pouvez ou la fermer
en cliquant sur le bouton  Fermer ou bien simplement la déplacer pour vérifier sur la carte le
résultat de votre sélection.
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Vous pouvez lire le nombre d'éléments sélectionnés en haut de la table attributaire :

Vous  venez  d'effectuer  une  requête  attributaire  simple.  Il  est
important  de  comprendre  qu'une  requête  ne  modifie  pas  les
données, elle les sélectionne simplement.

Bien  sûr,  il  est  plus  intéressant  d'utiliser  les  requêtes  pour
sélectionner plusieurs éléments en même temps !

3.3.2 Créer une nouvelle couche à partir d'une sélection

Il est possible de créer une nouvelle couche shapefile à partir d'une sélection.

Votre département du Nord étant toujours sélectionné, clic droit sur la couche de départements
→ Enregistrer sous... :

• cliquez sur  Parcourir pour choisir à quel endroit sera sauvegardée la nouvelle couche, et
sous quel nom : dept59 par exemple

• cochez la case N'enregistrer que les entités sélectionnées

• et cliquez sur OK 

La nouvelle couche est automatiquement ajoutée à QGIS. Elle ne contient qu'un seul département,
celui du Nord.

3.3.3 Quelques opérateurs

Dans l'exemple ci-dessus, nous avons utilisé l'opérateur = pour notre requête. Il en existe d'autres,
comme par exemple les opérateurs mathématiques < et >, *, /...

Ajoutez  la  couche  communes_NordPasDeCalais située  dans  le  dossier
3_manip_vecteur/donnees.

Fermez la  table attributaire de la couche de départements et  ouvrez celle  de la  couche de
communes.  Cette table comporte une colonne  POPULATION avec la population de chaque
commune en milliers d'habitants.

Nous allons faire une requête pour sélectionner les communes de + de 10 000 habitants.
Ouvrez la fenêtre de requête pour la couche de communes :

Formation CNRS QGIS 2.12, avril 2016 - julie.pierson@cnrs.fr 29/57

mailto:julie.pierson@cnrs.fr?subject=Formation%20QGIS%20CNRS
http://creativecommons.org/licenses/by-nc-sa/2.0/fr/


• Cliquez sur  Champs et valeurs pour voir la liste des champs, puis double-cliquez sur le
champ POPULATION 

• Dans la case Expression, tapez > 10 (puisque la population est en milliers d'habitants) 

Il est également possible d'aller chercher l'opérateur  > dans la liste des opérateurs, dans la
colonne du milieu. Il faut ensuite taper la valeur 10 à la main.

Une  fois  votre  requête  tapée,  cliquez  sur  le  bouton
Sélection pour voir le résultat.

La ligne Opérateurs visible dans la fenêtre de sélection n'en
comporte que quelques uns; vous pouvez tous les retrouver
dans la catégorie  Opérateurs de la colonne du milieu. En
cliquant  sur  un opérateur, vous pouvez lire  l'aide  dans la
partie de droite de la fenêtre.
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Intéressons-nous aux opérateurs LIKE et ILIKE. Ces deux opérateurs sont utilisées sur du texte.
L'opérateur LIKE permet de comparer une chaîne de caractère à une autre chaîne qui peut utiliser
le caractère joker %. 

Ce caractère peut remplacer un ou plusieurs caractères : par exemple, 'A%' peut correspondre à
Ardèche, Allier...

L'opérateur  ILIKE est équivalent à  LIKE mais ne tient pas compte de la casse (majuscules ou
minuscules).

Sélectionnons les communes dont le nom se termine par 'IN' :

Écrivez la requête suivante :

"NOM_COMM" LIKE '%IN'

(soit en la tapant à la main soit en double-cliquant sur les différents éléments).

3.3.4 Combiner plusieurs critères

Comment faire si l'on veut sélectionner par exemple les communes de + de 10 000 habitants dont
le nom se termine par 'IN' ?

Il s'agit ici de combiner deux critères. Deux opérateurs permettent cela : AND (et) et OR (ou).

• Avec l'opérateur AND, tous les critères doivent être remplis 
• Avec l'opérateur OR, il suffit qu'un seul des critères soit rempli 

Quelle requête utiliser pour sélectionner les communes de moins de 10 000 habitants dont le
nom commence par A ?

(indice : 98 communes seront sélectionnées)

Quelle requête utiliser pour sélectionner les communes de Lille, Roubaix et Tourcoing ?

Pour  ne  voir  que  les  lignes  sélectionnées  dans  la  table :  choisissez  Ne  montrer  que  les  entités
sélectionnées dans la liste déroulante en bas à gauche de la table.

3.3.5 Quelques exemples à tester

Pouvez-vous sélectionner ? ...

(plusieurs requêtes sont parfois possibles pour un même résultat)

La commune d'Arras ?

La commune de code INSEE 62041 ?

Les communes du département du Nord ? (650 communes sélectionnées)

Les communes dont le nom contient 'OO' ? (10 communes sélectionnées)

Les  communes  dont  le  nom  commence  par  'M'  et  se  termine  par  'in' ?  (4  communes
sélectionnées)
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Les communes dont la population est comprise entre 10 000 et 50 000 habitants inclus ? (71
communes sélectionnées)

Les  communes  du  département  du  Nord,  dont  le  nom  contient  ou  'w'  ou  'oo',  et  dont  la
population est inférieure ou égale à 10 000 habitants ? (55 communes sélectionnées)

Dans la  fenêtre  de requête  attributaire,  vous  pouvez retrouver  les dernières  requêtes utilisées dans la
colonne du milieu, rubrique « Récent (Sélection) ».

3.4. Sélectionner des entités selon leur géométrie

Nous venons de voir comment sélectionner des éléments en fonction des données de la table
attributaire ; nous allons voir ici comment sélectionner des éléments en fonction de leur position
par rapport aux éléments d'une autre couche.

Contrairement aux requêtes attributaires, les requêtes spatiales mettent donc le plus souvent deux
couches en jeu : une couche dans laquelle sera faite la sélection, et une couche de référence.

On peut par exemple, à l'aide d'une couche de points et d'une couche de polygones, sélectionner
tous les points situés dans les polygones.

3.4.1 Faire une requête spatiale simple

Créez  un  nouveau  projet  QGIS  et  ajoutez-y  la  couche  communes_NordPasDeCalais et la
couche eoliennes.

Le but va être ici de sélectionner toutes les communes du Nord-Pas-de-Calais sur lesquelles sont
implantées une ou plusieurs éoliennes.

Rendez-vous dans le menu Vecteur → Outils de recherche → Sélection par localisation.

• Sélection  d'entités  dans : il  s'agit  de  la  couche  dans  laquelle  sera  faite  la  sélection,
sélectionnez la couche de communes 

• qui  intersecte  les  entités  dans : il  s'agit  de  la  couche  par  rapport  à  laquelle  seront
sélectionnés les éléments, sélectionnez la couche d'éoliennes

• Cochez la case Inclure les entités en entrée qui intersectent les entités sélectionnées
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• Cliquez sur OK, vous pouvez ensuite fermer la fenêtre.

Les communes sélectionnées apparaissent en jaune, on peut lire en bas à gauche de la fenêtre
de QGIS le nombre d'entités sélectionnées : ici 117.

Il  existe  (au  moins)  une  autre  méthode  pour  effectuer  des  requêtes  spatiales  dans  QGIS.
Rendez-vous dans le menu  Extensions → Installer/Gérer les extensions. Dans la rubrique
Toutes, cochez la case Extension de requête spatiale.

(Cette extension est installée par défaut, mais non activée). Vous pouvez ensuite effectuer la
même requête à partir du menu Vecteur → Requête spatiale → Requête spatiale.

Ces  deux  outils  sont  à  peu  près  équivalents  mais  présentent  des  différence  au  niveau  des
opérateurs notamment. A vous de choisir lequel est le plus adapté en fonction de ce que vous
souhaitez faire !

3.4.2 Quelques exemples

Ajoutez la couche dept59 créée précédemment, ainsi que la couche COURD01 correspondant
aux cours d'eau de + de 100 km.

Entre  deux requêtes,  pour  être  sûr  de repartir  à  zéro,  utiliser  l'outil  Désélectionner
toutes les entités.

En utilisant différents opérateurs, pouvez-vous dire ?...

→ s'il y a des éoliennes qui ne sont pas dans une commune du Nord-Pas-de-Calais ? Pour
cette question il peut être plus simple d'utiliser l'extension de requête spatiale.

(4 éoliennes sur 440)

→ combien de communes sont traversées par un cours d'eau ? (482 communes sur 1545)

→ combien le département du Nord comporte-t-il de communes ? (650 communes sur 1545)
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3.5. Manipuler les géométries

Nous aborderons dans cette partie quelques traitements possibles sur des données vecteur. Il en
existe bien sûr beaucoup d'autres !

L'objectif sera ici d'étudier l'évolution des îlots de culture majoritairement en prairie entre 2010 et
2012, dans le canton de Maël-Carhaix en Côtes d'Armor.

Pour bien suivre les différentes étapes de cette partie, vous pouvez utiliser l'organigramme fourni
dans organigrammes/geotraitements vecteur.pdf)

3.5.1 Regrouper  des  entités  en  fonction  d'un  attribut :  agrégation  de  communes  pour
former les cantons

Créez un nouveau projet QGIS. Ajoutez-y la couche  communes_22_geofla,  qui correspond
aux communes du département des Côtes d'Armor.

Donnez au projet le même SCR que celui de la couche de communes.

Notre but sera ici de créer un polygone correspondant à notre zone d'étude, soit le canton de
Maël-Carhaix (code canton 23).

Dans un premier temps, pour simplement visualiser les différents cantons, nous allons représenter
les communes de manière différente suivant le code de canton. Cette étape n'est pas utile en soi
mais permet de mieux comprendre la manipulation.

Affichez les propriétés de la couche communes_22_geofla, rubrique Style :

Choisissez le mode Catégorisé au lieu de Symbole unique,
en fonction de la colonne CODE_CANT (code canton), avec
comme palette de couleur  Couleurs au hasard,  et  cliquez
sur Classer.

Cliquez sur OK : chaque commune est colorée suivant son
canton.
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Nous allons maintenant créer une couche de cantons à partir des communes, en fusionnant
toutes les communes ayant le même code canton.

Menu Vecteur → Outils de géotraitement → Regrouper :

•Couche vectorielle de saisie : sélectionnez la couche communes_22_geofla

•Vérifiez que la case Utiliser uniquement les valeurs sélectionnées soit décochée

•Champ de catégorie :  sélectionnez le champ selon lequel agréger les communes,  soit  
CODE_CANT

•Fichier de sortie : cliquez sur Parcourir pour choisir où créer la couche et lui donner un 
nom (cantons par exemple)

•Cochez la case Ajouter le résultat au canevas de la carte

•OK, puis fermer la fenêtre une fois l'opération terminée

Le résultat est ajouté à QGIS.

Si  vous  ouvrez  la  table  attributaire  de  cette  couche,  vous  pourrez
constater  qu'un  certain  nombre  des  champs  n'ont  plus  de  sens…
Nous verrons partie 4.3.1 comment supprimer des champs.

Il ne reste plus ensuite qu'à créer une couche ne comportant que le canton de Maël-Carhaix,
code canton 23. Pour cela, sélectionnez ce canton à l'aide d'une requête attributaire, et créez
une nouvelle couche à partir de la sélection, que vous nommerez canton23 (cf. 3.3.2 Créer une
nouvelle couche à partir d'une sélection).

Une autre  méthode,  légèrement  plus rapide,  aurait  pu être  utilisée pour créer  cette  couche,,  avec une
sélection préalable... Pouvez-vous la trouver ?

3.5.2 Découper une couche par une autre

Ajoutez  les  couches RPG_2010_022_prairies et  RPG_2012_022_prairies.  Ces  2  couches
correspondent à des îlots de culture majoritairement en prairie pour 2010 et 2012.
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Le but sera ici de découper ces deux couches pour ne garder que les îlots du canton de Maël-
Carhaix.

Menu Vecteur → Outils de géotraitement → Découper :

• Couche vectorielle de saisie : sélectionnez la couche de prairies 2010

• Couche de découpage : choisir la couche servant de masque de découpe, en l'occurrence
le canton 23

• Fichier  de  sortie : cliquez  sur  Parcourir,  choisissez  l'endroit  où  la  couche  sera  créée,
donnez lui un nom, par exemple RPG_2010_canton23_prairies

• Cliquez sur OK 

Contrairement à une requête spatiale, le découpage modifie les entités en les découpant suivant
les limites de la couche de découpage. Une requête se borne à sélectionner par exemple les îlots
à l'intérieur des communes, ou intersectant les communes, comme ci-dessous :

Répétez  l'opération  pour  découper  la  couche  RPG_2012_022_prairies  par  le  canton  23.
Nommez la couche obtenue RPG_2012_canton23_prairies.

Ouvrez la table attributaire de l'une ou l'autre couche obtenue par découpage ; elle contient les
mêmes champs que la couche initiale d'îlots RPG.

3.5.3 Données communes entre deux couches : intersection

L'intersection entre deux couches crée une troisième couche, avec uniquement
les parties communes aux deux couches.

Nous allons ici intersecter les prairies de 2010 et de 2012, pour voir les îlots en
prairie aux 2 années, pour le canton 23.

Rendez-vous dans le menu Vecteur → Outils de géotraitement → Intersection :

Formation CNRS QGIS 2.12, avril 2016 - julie.pierson@cnrs.fr 36/57

Découpage Requête spatiale

mailto:julie.pierson@cnrs.fr?subject=Formation%20QGIS%20CNRS
http://creativecommons.org/licenses/by-nc-sa/2.0/fr/


• Couche vectorielle de saisie : choisir la couche de  prairies 2010 du canton 23. Ne pas
cocher la case « Utiliser uniquement les entités sélectionnées » puisqu'il s'agit d'intersecter
toutes les prairies

• Couche d'intersection : choisir la couche de prairies 2012 du canton 23. Idem, ne pas
cocher la case « Utiliser uniquement les entités sélectionnées »

• Fichier de sortie : cliquez sur  Parcourir, tapez le nom (intersection_prairies_2010_2012
par exemple) et l'emplacement de la couche qui sera créée

Cliquez sur OK, fermez la fenêtre d'intersection.

Vous devez obtenir une couche similaire
à celle de l'illustration.

Ouvrez  la  table  attributaire  de  cette
couche : notez que les champs des deux
couches de départ sont présents.

3.5.4 Pour  aller  plus  loin :  manipuler  des  données  attributaires  en  calculant  le  %  de
prairies 2010 restées en prairies en 2012

Le but est de calculer quel % des prairies 2010 est resté en prairie en 2012.

Pour cela, il faudra calculer :
• la somme des surfaces en prairies en 2010 (couche RPG_2010_canton23_prairies)
• la  somme  des  surfaces  en  prairies  communes  entre  2010  et  2012  (couche

intersection_prairies_2010_2012)
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Ouvrez la table attributaire de la couche RPG_2010_canton23_prairies. Nous allons ajouter un
champ surface à cette table et calculer pour chaque entité sa surface en hectares.

Pour pouvoir éditer la couche, cliquez sur l'icône  Activer le mode d'édition en haut à
gauche de la table (par défaut, les couches sont verrouillées et ne peuvent être modifiées).

Cliquez ensuite sur l'icône Ouvrir la calculatrice de champs en haut à droite de la table.

La calculatrice de champ permet la création et le calcul de champs.

• Choisissez Créer un nouveau champ, nommez le surf_ha, choisissez le type décimal, une
longueur de 10 et une précision de 2 (2 chiffres après la virgule)

• Dans la liste des fonctions, dans la rubrique géométrie, double-cliquez sur la fonction $area
puis rajoutez dans la case expression / 10 000 (par défaut, la surface est calculée en unités
de la couche, donc en m2 puisque la couche est projetée en Lambert 93, et 1ha = 10 000m2)

• Au final, l'expression est donc $area / 10 000 

• Cliquez sur OK

Quittez  le mode édition,  en  enregistrant  les  modifications ;  la  colonne est  ajoutée et
remplie.

Vous pouvez vérifier le calcul pour un îlot, en mesurant sa surface « à la main » avec l'outil
Mesurer une aire, et en comparant le résultat avec celui de la table : les 2 résultats doivent être
proches.
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Procédez de la même manière pour créer et calculer un champ surface en hectare pour la
couche  d'intersection  intersection_prairies_2010_2012.  N'oubliez  pas  de  quitter  le  mode
édition une fois l'opération terminée.

Pour calculer la somme des surfaces pour une couche :

menu Vecteur → Outils d'analyse → Statistiques basiques :

• Couche vectorielle en entrée : RPG_2010_canton23_prairies

• Champ ciblé : surf_ha

Cliquez sur OK, notez la somme obtenue pour 2010 :

Procédez de la même manière pour obtenir la somme des surfaces de prairies présentes en
2010 et 2012 :

Quel est le % de prairies 2010 restant en prairie en 2012 ?
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4. MANIPULER DES DONNÉES RASTER

Notions abordées :

• Modification du SCR d'un raster
• Découpage de raster par un polygone
• Analyse de terrain (calcul de pente)
• Statistiques zonales
• Calcul raster

Dans cette quatrième partie, nous verrons quelques exemples de manipulations sur des données
raster :  gérer  les  systèmes  de  coordonnées,  croiser  données  raster  et  vecteur,  croiser  des
données raster et traiter des données d'altitudes.

Pour  cela,  nous  allons  continuer  à  travailler  sur  les  prairies  de  Côte  d'Armor.  Nous  allons
télécharger un Modèle d’Élévation Numérique, le projeter et le découper par notre zone d'étude,
puis créer un nouveau raster de pente à partir de ce raster d'élévation. Ce raster de pente nous
servira à calculer pour chaque îlot de culture en prairie sa pente moyenne.

A  partir  des  mêmes  couches  que  précédemment  (prairies  2010  et  2012),  nous  testerons
l'intersection en utilisant cette fois des données raster au lieu de vecteur.

Pour bien suivre les différentes étapes de cette partie, vous pouvez réaliser vous-même, sur
papier, un organigramme similaire à celui utilisé en 3.5.

4.1. Télécharger une dalle SRTM, la projeter et la découper

Le  modèle  SRTM  est  un  Modèle  d’Élévation  Numérique  (cf.  1.3.4)  issu  d'une  collaboration
NASA/NGA (National Geospatial-Intelligence Agency). Ces données sont en téléchargement libre.

Dans un navigateur internet, rendez-vous sur : http://dwtkns.com/srtm/

et cliquez sur la case recouvrant l'ouest de la France (dalle 36_03).

Téléchargez  cette  dalle,  enregistrez-la  dans  le  dossier
4_manip_raster/donnees et  décompressez-la  (au  cas  où  le
téléchargement  ne  fonctionnerait  pas,  la  dalle  est  disponible
dans votre dossier 4_manip_raster).

Dans QGIS, créez un nouveau projet et ajoutez la couche raster
srtm_36_03.tif. Dans quel SCR est cette couche ?

Les pixels « dans la mer » sont affichés comme « sans données ». En réalité, chaque pixel d'un
raster ayant une valeur, ils ont bien une donnée associée. Pour savoir laquelle, rendez-vous
dans  les  propriétés  de  la  couche,  rubrique  Métadonnées,  chercher  Aucune  valeur  de
données dans le bas de la fenêtre, noter la valeur.
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Dans la mesure où toutes nos autres couches (prairies, communes) sont en RGF93 Lambert93,
et  où l'élévation  est  mesurée en mètres,  il  est  plus facile  de travailler  également  avec des
coordonnées en mètres en XY, et donc de projeter le raster en Lambert 93.

Menu Raster → Projections → Projection...

• Fichier source : srtm_36_03

• Fichier en sortie : cliquer sur Sélection, choisir l'emplacement et taper le nom de la couche
qui sera créée : srtm_36_03_L93

• SCR source : il est lu automatiquement

• SCR cible : cliquer sur Sélection, choisir le RGF93 Lambert 93 (code EPSG 2154)

• Données sans valeurs : choisir la même valeur que celle de srtm_36_03, soit -32768

• Cocher la case Charger dans le canevas une fois terminé

OK, patientez... La nouvelle couche est ajoutée dans QGIS ; vérifiez son SCR.

La prochaine étape sera de découper ce raster pour ne garder que la zone du canton de Maël-
Carhaix.

Notez qu'on aurait  pu sauter  cette étape en sélectionnant  la  couche du canton 23 comme  couche de
masquage en  réalisant  la  projection.  Mais  faire  cette  opération  en  2  étapes  nous  permet  de  voir  le
fonctionnement de 2 outils.

Ajoutez à QGIS la couche canton23 créée en 3.5.1 p.  34. Si vous avez sauté cette étape, la
couche est également disponible dans le dossier 4_manip_raster/donnees.

Menu Raster → Extraction → Découper...
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• Fichier source : srtm_36_03_L93

• Fichier  en  sortie :  cliquez  sur  Sélection...,  choisir  l'emplacement,  taper  le  nom :  
srtm_canton23_L93

• Valeur nulle : -32768

• Mode de découpage : couche de masquage, avec la couche canton23

La nouvelle couche doit ressembler à l'illustration ci-contre.

4.2. Calculer la pente à partir de l'altitude

Il est possible de créer à partir d'un raster d'altitude un raster de pente : chaque
pixel aura la valeur de la pente en ce point.

La pente est calculée en fonction de la distance horizontale et de la hauteur (d'où
l'importance d'avoir préalablement projeté le raster, pour que distance horizontale
et hauteur soient dans la même unité).

Pour  en  savoir  plus  sur  le  mode  de  calcul  de  la  pente  à  partir  de  l'altitude :
http://help.arcgis.com/fr/arcgisdesktop/10.0/help/index.html#/na/009z000000vz000000/

Menu Raster → Analyse → MNT/DEM (Modèles de terrain) :

Formation CNRS QGIS 2.12, avril 2016 - julie.pierson@cnrs.fr 42/57

mailto:julie.pierson@cnrs.fr?subject=Formation%20QGIS%20CNRS
http://help.arcgis.com/fr/arcgisdesktop/10.0/help/index.html#/na/009z000000vz000000/
http://creativecommons.org/licenses/by-nc-sa/2.0/fr/


• Fichier  source : sélectionnez
srtm_canton23_L93

• Fichier  en  sortie : cliquez  sur
Sélection... et  sélectionnez
l'emplacement de la couche qui  sera
créée,  tapez  son  nom :
pente_canton23_L93

• Mode : choisir  Pente dans  la  liste
déroulante 

• Cochez  la  case  Charger  dans  la
carte une fois terminé 

• Laissez  les  autres  paramètres  par
défaut

Pour plus d'infos sur les méthodes de Zevenberger & Thorne et Horn :
http://www.macaulay.ac.uk/LADSS/documents/DEMs-for-spatial-modelling.pdf, p. 12 et 13)

Cliquez sur OK, patientez... la couche s'affiche.

Ici, les pixels sombres représentent des pentes faibles et les
pixels clairs de fortes pentes.

En cliquant sur un pixel avec l'outil Identifier les entités, vous
pouvez connaître la valeur de la pente pour ce pixel :

Ici, le pixel a une pente de 13,5° environ.
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4.3. Croiser des données vecteur et raster : pente moyenne par parcelle

Ajoutez  à  QGIS  la  couche  vecteur  RPG_2010_canton23_prairies créée  en  3.5.2,
correspondant aux îlots de culture en prairie majoritaire pour le canton 23, en 2010. Si vous
avez  sauté  cette  étape,  la  couche  est  également  disponible  dans  le  dossier
4_manip_raster/donnees.

Le but va être ici de calculer pour chaque parcelle sa pente moyenne.

4.3.1 Calcul de pente moyenne par parcelle

L'outil  de  statistiques  de zone  permet,  à  partir  d'une  couche  vecteur  et  d'une  couche  raster,
d'ajouter 3 champs à la couche vecteur correspondant à la somme et la  moyenne des valeurs
des pixels  du  raster  pour  chaque polygone,  et  au  nombre  de pixels du  raster  pour  chaque
polygone.

Menu Raster → Statistiques de zone → Statistiques de zone

• Couche raster : pente_canton23_L93

• Couche de polygone : RPG_2010_canton23_prairies

• Préfixe de la colonne en sortie : pente_

Lancez le calcul en cliquant sur OK.

Cet outil ne crée pas de nouvelle couche mais modifie directement la couche de polygones.

Ouvrez la table attributaire de RPG_2010_canton23_prairies :

Les  champs  pente_coun(nombre  de  pixels),  pente_sum  (somme des  valeurs  de  pente)  et
pente_mean (moyenne des valeurs de pente) ont été ajoutés.

Seul le champ pente_mean nous intéresse. Pour supprimer les 2 autres :

Passez en mode édition, puis cliquez sur l'icône Supprimer une colonne.
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Supprimez les 2 champs pente_coun et pente_sum, et quittez le mode édition.

Y a-t-il des valeurs de pente_mean aberrantes ? Pourquoi ?

Pour masquer ces valeurs (les polygones n'apparaîtront plus sur la carte ni dans la table) :

Clic droit sur la couche, Filtrer : utilisez l'expression "pente_mean" >= 0

Notez que lorsqu'une requête est activée de cette manière, la couche ne peut être éditée.

Appliquez les changements, fermez et rouvrez éventuellement la table
attributaire : les valeurs aberrantes sont masquées.

En choisissant un style  gradué, vous pouvez représenter les îlots en
fonction de leur pente moyenne.

4.4. Intersecter des données raster

Dans  la  partie  3.5.3,  nous  avons  intersecté  2  couches  vecteur.  Il  est  possible  de  faire  une
manipulation équivalente sur des couches raster, ce que nous allons tester ici.

Le but sera donc encore une fois de terminer quels sont les prairies communes entre 2010 et
2012.

Ouvrez un nouveau projet QGIS, ajoutez les couches vecteur  RPG_2010_canton23_prairies et
RPG_2012_canton23_prairies créées  précédemment  (également  disponibles  dans  le  dossier
4_manip_raster/donnees).

4.4.1 Rasterisation de couche vecteurs

La première étape va consister à transformer nos 2 couches vecteur en couches raster. Pour
pouvoir ensuite facilement croiser les 2 rasters, nous allons ajouter à chacune de nos couches
vecteur un champ, rempli par la même valeur pour toutes les entités.

Utilisez la calculatrice de champ (cf. 3.5.4 p. 37) pour ajouter aux 2 couches un champ VAL de
type entier, rempli par :

• 1 pour les prairies 2010

• 2 pour les prairies 2012,

en tapant simplement 1 ou 2 dans la case Expression.
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Quittez le mode édition pour les 2 couches.

Puis menu Raster → Conversion → Rastériser :

• Fichier source : RPG_2010_canton23_prairies

• Champ d'attribut : VAL

• Fichier de sortie : cliquez sur Sélection..., choisissez où la couche sera créée et donnez-lui
un nom, par exemple RPG_2010_canton23_prairies.tif

• Choisir l'option Résolution exprimée en unités de la carte par pixel, avec des pixels de 
10m par 10m

• OK, patientez... : la couche est ajoutée à QGIS.

Cette couche doit contenir les valeurs 0 (hors îlot) et 1 (îlot) : vérifiez-le en l'interrogeant
au moyen de l'outil Identifier les entités.

Faites de même pour créer une couche raster  RPG_2012_canton23_prairies.tif à partir  de
RPG_2012_canton23_prairies.shp.

Vérifiez que cette couche contienne les valeurs 0 (hors îlot) et 2 (îlot).

4.4.2 Croiser des raster : calculatrice raster

Nous allons additionner ces 2 rasters : 

• là où les îlots se recouvrent, l'addition aura une valeur de 3 (1 + 2)
• là où seul un îlot 2010 est présent, l'addition aura une valeur de 1 (1 + 0)
• là seul un îlot 2012 est présent, l'addition aura une valeur de 2 (2 + 0)

Menu Raster → Calculatrice Raster :
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• Couche en sortie : cliquez sur … , choisissez où la couche sera créée et tapez son nom :
inters_prairies_2010_2012

• Expression  de  la  calculatrice  raster :  double-cliquez  sur  RPG_2010_canton23_prairies
dans la liste en haut à gauche, puis sur le signe +, et enfin sur RPG_2010_canton23_prairies,
pour obtenir "RPG_2010_canton23_prairies@1" + "RPG_2012_canton23_prairies@1"

OK, le raster créé est ajouté à QGIS.

Modifiez le style de ce raster pour voir les différentes valeurs : propriétés de la couche, rubrique
Style, type de rendu Pseudo-couleur à bande unique. Cliquez sur le bouton + pour ajouter 3
valeurs, modifiez les valeurs par défaut (0.0) en double-cliquant dessus pour que les 3 valeurs
soient 1, 2 et 3, modifiez éventuellement les couleurs en double-cliquant sur les rectangles de
couleur à droite des valeurs.
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Et rendez-vous également dans la rubrique Transparence pour ajouter 0 en valeur nulle, afin
de ne pas afficher les pixels de valeur 0 :

Au final,  vous pouvez obtenir  quelque chose de similaire  à
l'image  ci-contre  (en  marron,  les  pixels  en  prairie  aux  2
années, en rose les pixels en prairie uniquement en 2010 et
en vert les pixels en prairie uniquement en 2012).

L'addition de couches raster est une opération plus rapide que
l'intersection  de  couches vecteur,  mais  peut  nécessiter  une
rastérisation  préalable  et  donc  une  perte  de  précision  par
rapport aux couches de départ.
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5. REPRÉSENTER DES DONNÉES ET LES METTRE EN PAGE

Notions abordées :

• symboles proportionnels
• cartes choroplèthes
• cartes en semis de points
• mise en page de cartes (composeur d'impression)

Les logiciels  SIG sont  avant  tout  des  logiciels  d'analyse spatiale.  Ils  permettent  également  la
représentation  des  données  sous  différentes  formes,  et  la  mise  en  page  de  cartes,  mais
présentent quelques limitations dans ces domaines.

Les règles de sémiologie graphique ne seront pas ou peu abordées ici, nous verrons avant tout
l'aspect « technique » sous QGIS.

5.1. Analyses thématiques

Il  existe  de  nombreuses  manières  de  représenter  les  données,  nous  en  verrons  seulement
quelques unes ici.

A partir d'une couche de communes et leur population, nous allons voir différentes manières de
visualiser cette population.

Créez  un  nouveau  projet  QGIS,  ajoutez  la  couche  COMMUNE.shp située  dans
5_repr/donnees.

5.1.1 Représenter des quantités ou des effectifs : carte en symboles proportionnels

Les cartes en symbole proportionnels permettent la représentation de quantités ou d'effectifs par
des  symboles,  généralement  des  cercles.  La  surface  des  symboles  sera  proportionnelle  à  la
quantité ou l'effectif.

Dans  QGIS,  la  visualisation  de  données  sous  forme de  cercles  proportionnels  nécessite  une
couche  de  points.  A  partir  de  la  couche  de  communes,  nous  allons  créer  les  centroïdes
(barycentres) des communes.

Menu Vecteur → Outils de géométrie → Centroïdes de polygones

• Couche en entrée : COMMUNE

• Fichier de points en sortie : cliquez sur 
Parcourir, choisir l'emplacement, tapez le 
nom : communes_centroides

La  couche  de  centroïdes  est  ajoutée  à  QGIS :  un  point  a  été  créé  par
commune.
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Rendez-vous dans les propriétés de la couche de centroïdes → rubrique  Style →  bouton à
droite de Taille → Assistant Taille...

Choisissez le champ : POPULATION et la méthode de calcul : Surface.

Vous pouvez jouer sur les différents paramètre pour obtenir une visualisation correcte de la
population à l'échelle d'un département ou d'une région (à l'échelle du pays, cela nécessiterait
d'agréger les cercles entre eux pour un meilleur rendu). Vous avez à votre disposition la couche
DEPARTEMENT dans le dossier 5_repr/donnees.

Comme  vous  l'avez  peut-être  remarqué,  QGIS  affiche  les
cercles dans l'ordre de la  table ;  il  peut  donc arriver que de
petits cercles soient masqués par de plus gros cercles. Pour
corriger cela :

clic droit sur la couche, Filtrer, tapez la requête :

1=1 ORDER BY POPULATION DESC

Attention, il ne doit pas y avoir de guillemets autour de POPULATION.

5.1.2 Représenter des variables relatives à des surfaces : cartes choroplèthes

Une carte choroplèthe est une carte en aplats de couleurs. Les régions sont colorées selon une
mesure statistique telle que la densité de population ou le revenu par habitant. Ce type de carte ne
peut  donc être utilisé pour  représenter des quantités ou des effectifs.  Les variables continues
doivent être discrétisées pour produire des classes.
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La  première  étape  consistera  pour  nous  à  créer  un  champ densité  de  population,  rempli  en
fonction de la population et la surface.

Ouvrez la table attributaire de COMMUNE, passez en mode édition et ouvrez la calculatrice de
champ.

Sachant  que la  population est  exprimée en milliers  d'habitants et  la  superficie  en hectares,
calculez dans un nouveau champ nommé densite de type décimal la densité de population en
nombre d'habitants par km2.

Quittez le mode édition.

Pour faire varier la couleur des communes en fonction de la densité :

Propriétés de la couche COMMUNE → rubrique Style

Sélectionnez le  style  Gradué en fonction de la  colonne  densite.  Choisissez un nombre de
classes et une méthode de discrétisation. Cliquez sur Classer et appliquez les changements.

Pour un meilleur rendu, vous pouvez supprimer les bordures
des communes en cliquant  sur  Modification... à  droite  de
Symbole  puis  sur  Remplissage  simple →  Style  de  la
bordure → Pas de ligne.

Pour voir l'effectif de chaque classe, clic droit sur le nom de la
couche → Montrer le décompte des entités.

Testez  différents  modes  de  discrétisation  et  nombres  de
classes. Notez qu'on peut aussi visualiser l'histogramme de
fréquence et y définir les bornes de classes.
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5.1.3 Représenter des quantités ou des effectifs : cartes en semis de points

Une  carte  en  semis  de  points  permet,  à  partir  d'un  maillage  surfacique,  de  représenter  des
quantités ou effectifs par des points placés aléatoirement au sein de chaque polygone. Le nombre
de ces points est proportionnel à la quantité ou l'effectif lié au polygone.

Nous allons créer ces points aléatoires en fonction du champ POPULATION. Ce champ étant
décimal avec un chiffre après la virgule, nous allons le multiplier par 10 pour obtenir des nombres
entiers (il n'est pas possible de créer 0,7 points dans un polygone...).

Ajoutez un champ nommé  POP10,  de type  entier,  égal  à 10 fois  le  champ POPULATION.
N'oubliez pas de quitter le mode édition une fois l'opération terminée.

Pour créer les points aléatoires : menu Vecteur → Outils de recherche → Points aléatoires

• Couche en entrée : COMMUNE

• Taille d'échantillon : utiliser la valeur du champ POP10

• Fichier  de  sortie :  cliquez  sur  Parcourir,  sélectionnez  
l'emplacement  et  tapez  le  nom :  
points_aleatoires_communes par exemple

• Ajouter le résultat au canevas de la carte

• OK,  patientez, l'opération est un peu longue...  et fermez la
fenêtre une fois terminé.

Ajustez le style de la couche, par exemple à l'échelle du pays :
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5.2. Mise en page de cartes

Une fois vos données représentées de manière satisfaisante, il peut être utile d'en faire une carte.
Cette partie n'a pas pour but d'expliquer les bonnes et mauvaises pratiques en matière de
cartographie,  mais  se  bornera  à décrire quelques fonctionnalités  du mode mise en page de
QGIS.

L'exercice consistera ici à mettre en page une carte de la densité de population par communes
(carte choroplèthe) en France.

5.2.1 Préparation de la mise en page

Commencez par ajouter toutes les couches dont vous avez besoin, et supprimez toutes les
couches inutiles.

Choisissez le style de chacune des couches.

N'oubliez pas également de choisir un SCR adapté pour votre projet (projeté si vous souhaitez
créer une échelle en mètres par exemple) (cf. 2.3.1 p. 18).

5.2.2 Mise en page

Le  mode  mise  en  page  se  nomme  composeur  d'impression dans  QGIS.  C'est  dans  le
composeur d'impression que vous pourrez ajouter une échelle, un titre etc. à votre carte.

Menu Projet → Nouveau composeur d'impression

Tapez un titre, par exemple densité communes.

Le principe du composeur  d'impression est  simple :  l'onglet  Composition permet  de fixer  les
paramètres de la page, et l'onglet  Propriétés de l'objet les paramètres de l'objet actuellement
sélectionné.

La première étape consiste à déterminer les dimensions de la page. S'il s'agit d'une figure destinée
à  être  intégrée  dans  un  rapport,  vous  pouvez  très  bien  choisir  une  taille  personnalisée,  par
exemple 15 x 15 cm.

Dans l'onglet Composition → Options du papier, choisissez Personnalisation au lieu de A4.
Fixez ensuite la largeur et la hauteur à 150 mm.

Pour zoomer sur la page : menu Vue → Zoom sur l'emprise totale ou clic sur l'icône
correspondante/

Cliquez ensuite sur  l'icône  Ajouter  une nouvelle carte (ou menu  Mise en page →
Ajouter une carte).

Dessinez un rectangle n'importe où sur la page, de la taille que vous voulez. Puis rendez-vous
dans l'onglet Propriétés de l'objet, rubrique Position et taille, et fixez X et Y à 0 et la largeur
et hauteur à 150 mm pour que la carte coïncide avec la page.
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Pour  centrer  la  carte :  cliquez sur  l'icône  Déplacer  le  contenu de l'objet et  faites
glisser le contenu de la carte.

Pour zoomer et dézoomer : vous pouvez utiliser la molette de la souris après avoir sélectionné
l'outil Déplacer le contenu de l'objet , ou modifiez l'échelle dans les propriétés de la carte :

La carte est liée à QGIS : si vous modifiez le style d'une couche dans QGIS, il sera également
modifié dans la carte du composeur.

Pour ajouter une légende : icône Ajouter une nouvelle légende, puis cliquez n’importe où
sur la carte.

Vous pouvez modifier les paramètres de la légende dans l'onglet Propriétés de l'objet, si elle
est sélectionnée.

Pour sélectionner un objet : outil Sélectionner/Déplacer un objet

Pour  ajouter du  texte, par exemple un titre, les sources, l'auteur... : outil  Ajouter une
étiquette.

Pour ajouter une  échelle :  outil  Ajouter une échelle graphique,
puis ajustez ses paramètres.

La mise en page est sauvegardée dans le projet. Pour sauvegarder votre mise en page, il faut
donc sauvegardez votre projet : dans la fenêtre de QGIS, menu Projet → Enregistrer sous...,
sauvegardez-le dans le dossier 5_repr/projets.

Plusieurs mises en page peuvent être sauvegardées dans un même projet. Pour gérer plusieurs mises en
page : menu Projet → Gestionnaire de composeurs.

Pour  exporter  votre  mise  en  page  au  format  image :  à  partir  du  composeur,  menu
Composeur  → Exporter  comme image....  De  nombreux  formats  sont  disponibles :
PNG, JPEG, TIFF, EPS...
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Pour pouvoir retoucher votre carte dans un logiciel de dessin vectoriel type Inkscape ou
Adobe Illustrator : menu Composeur → Exporter au format SVG...

L'export au format SVG peut poser quelques problèmes, en particulier pour gérer la transparence. L'export
au format PDF peut parfois être plus pratique pour ensuite retoucher la carte dans un logiciel de dessin.

Exemple de carte réalisée avec QGIS :
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6. RECHERCHE ET AJOUT DE DONNÉES SIG VIA D'AUTRES SOURCES

Liste non exhaustive et en vrac de sites où trouver des données SIG

L'annuaire  de  données  du  GeoRezo,  portail  francophone  de  la  géomatique
http://georezo.net/annuaire/donnees-c-4.html

Natural Earth : données à l'échelle mondiale : limites administratives, hydrographie, bathymétrie,
fonds de carte raster...
http://www.naturalearthdata.com/downloads/

FAO (Food and Agriculture Organisation) : catalogue de métadonnées donnant  accès à un
large éventail de données vecteur ou raster, en particulier sur les pays du Sud.
http://www.fao.org/geonetwork/

CUB (Communauté Urbaine de Bordeaux) : données thématiques sur la CUB
http://data.lacub.fr/themes.php

OpenStreetMap : extractions de données au format SHP ou OSM, fourni par Geofabrik :
http://download.geofabrik.de/openstreetmap/

IGN : nombreuses données disponibles pour la France, certaines gratuites pour les établissements
de recherche
http://professionnels.ign.fr/catalogue

GADM : limites administratives accessibles par pays
http://www.gadm.org/

DIVA-GIS : site du logiciel SIG libre DIVA, où sont aussi disponibles des données vecteur sur les
limites administratives, l'hydrographie, le transport, la population... classées par pays
http://www.diva-gis.org/gdata

ASTER : modèle d'élévation, données mondiales téléchargeables par dalles
http://asterweb.jpl.nasa.gov/gdem.asp

SRTM : modèle d'élévation, données mondiales téléchargeables par dalles
http://dwtkns.com/srtm/

Global Land Cover Facility : images satellites
http://glcfapp.glcf.umd.edu:8080/esdi/

Flux WMS et WFS

Il est possible de visualiser directement dans un SIG des données accessibles sur un serveur,
sans devoir préalablement les télécharger sur votre ordinateur. Ceci se fait via des flux. Les deux
types de flux les plus courant permettant ceci sont les flux WMS (Web Map Service) et WFS (Web
Feature Service).

• Les flux WMS vont vous permettre d'afficher des couches raster, non modifiables. 
• Les flux WFS vous permettront d'afficher des couches vecteur, non directement modifiables

mais que vous pourrez ensuite télécharger au format shapefile.

Pour savoir comment se connecter à un flux dans QGIS :
http://cms.geobretagne.fr/content/r%C3%A9utilisation-avec-qgis

Pour des adresses de flux, voir la liste du CEREGE :
https://www.cerege.fr/spip.php?article276
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Visualiser les données d'OpenStreetMap, Google Maps etc. dans QGIS : installation d'une
extension

Il est possible d'afficher directement dans QGIS les données OpenStreetMap, Google Maps et
autres. Ceci nécessite l'installation de l'extension OpenLayers.

Dans QGIS, rendez-vous dans le menu Extensions → Installer/Gérer les extensions :

Dans la rubrique Toutes, tapez openlayers dans la partie rechercher en haut de la fenêtre, pour
ne voir que les extensions dont le nom contient openlayers.

Cliquez sur l'extension OpenLayers Plugin puis sur le bouton Installer l'extension.

Fermez la fenêtre du gestionnaire d'extensions.

L'extension  OpenLayers  est  accessible  à  partir  du  menu  Internet  → OpenLayers  plugin.
Choisissez une couche à ajouter.

Notez que l'ajout d'une couche via OpenLayers entraîne automatiquement la modification du SCR
du projet vers le SCR Pseudo-Mercator, code EPSG 3857

Il  est  possible  de  modifier  à  nouveau  le  SCR du  projet,  mais  cela  peut  entraîner  des  bugs
d'affichage.

Par ailleurs, l'utilisation de couches OpenLayers pour exporter des cartes via le composeur
d'impression peut aussi comporter des bugs : décalage des couches les unes par rapport aux
autres.
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